blob: 04a63c3a9fb478ef2570991b617ec57dfb39a60a [file] [log] [blame]
#!/usr/bin/make -f
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.
# $Id$
TCL_VERSION=8.3
package=libapache-mod-dtcl
build:
$(checkdir)
( export C_INCLUDE_PATH=/usr/include/tcl$(TCL_VERSION)/ ; APACHE=/ ./builddtcl.sh EXTRA_FLAGS=-DEAPI )
touch build
clean:
$(checkdir)
-rm -f build
-make clean
-rm -f `find . -name "*~"`
-rm -rf debian/tmp debian/files* core debian/substvars
binary-indep: checkroot build
$(checkdir)
# There are no architecture-independent files to be uploaded
# generated by this package. If there were any they would be
# made here.
binary-arch: checkroot build
$(checkdir)
-rm -rf debian/tmp
install -d debian/tmp
cd debian/tmp && install -d `cat ../dirs`
cp mod_dtcl.so debian/tmp/usr/lib/apache/1.3/
cp debian/400mod_dtcl.info debian/tmp/usr/lib/apache/1.3/
dh_installdocs docs/ contrib/
dh_installchangelogs
dh_installmanpages
dh_movefiles
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_makeshlibs
dh_md5sums
dh_builddeb
dpkg-gencontrol
chown -R root.root debian/tmp
chmod -R go=rX debian/tmp
dpkg --build debian/tmp ..
define checkdir
test -f debian/rules
endef
binary: binary-indep binary-arch
checkroot:
$(checkdir)
test root = "`whoami`"
.PHONY: binary binary-arch binary-indep clean checkroot