blob: a265c8dba7955b7d39abc7b0ad6bc236b3e9ccf9 [file] [log] [blame]
<!--
~ Licensed to the Apache Software Foundation (ASF) under one
~ or more contributor license agreements. See the NOTICE file
~ distributed with this work for additional information
~ regarding copyright ownership. The ASF licenses this file
~ to you under the Apache License, Version 2.0 (the
~ "License"); you may not use this file except in compliance
~ with the License. You may obtain a copy of the License at
~
~ http://www.apache.org/licenses/LICENSE-2.0
~
~ Unless required by applicable law or agreed to in writing,
~ software distributed under the License is distributed on an
~ * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
~ KIND, either express or implied. See the License for the
~ specific language governing permissions and limitations
~ under the License.
-->
<project
xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.apache.synapse</groupId>
<artifactId>Apache-Synapse</artifactId>
<version>2.0.0-SNAPSHOT</version>
<relativePath>../../pom.xml</relativePath>
</parent>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-distribution</artifactId>
<name>Apache Synapse - Distribution</name>
<description>Apache Synapse - Distribution</description>
<packaging>pom</packaging>
<dependencies>
<dependency>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-extensions</artifactId>
<version>${pom.version}</version>
</dependency>
<dependency>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-samples</artifactId>
<version>${pom.version}</version>
</dependency>
<dependency>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-experimental</artifactId>
<version>${pom.version}</version>
</dependency>
<dependency>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-config-migrator</artifactId>
<version>${pom.version}</version>
</dependency>
<!-- Wrapper jars -->
<dependency>
<groupId>wrapper</groupId>
<artifactId>wrapper</artifactId>
<version>${wrapper.version}</version>
</dependency>
<!-- The distribution is configured for log4j. Normally, log4j should not
be a transitive dependency, so we need to declare it explicitly. -->
<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
</dependency>
<!-- Modules -->
<dependency>
<groupId>org.apache.rampart</groupId>
<artifactId>rampart</artifactId>
<version>${rampart.version}</version>
<exclusions>
<exclusion>
<groupId>org.apache.woden</groupId>
<artifactId>woden-api</artifactId>
</exclusion>
<exclusion>
<groupId>org.apache.xalan</groupId>
<artifactId>xalan</artifactId>
</exclusion>
</exclusions>
<type>mar</type>
</dependency>
<dependency>
<groupId>org.apache.sandesha2</groupId>
<artifactId>sandesha2</artifactId>
<version>${sandesha2.version}</version>
<exclusions>
<exclusion>
<groupId>org.apache.axis2</groupId>
<artifactId>axis2</artifactId>
</exclusion>
</exclusions>
<type>mar</type>
</dependency>
<dependency>
<groupId>org.apache.axis2</groupId>
<artifactId>addressing</artifactId>
<version>${addressing.version}</version>
<type>mar</type>
<exclusions>
<exclusion>
<groupId>org.apache.geronimo.specs</groupId>
<artifactId>geronimo-javamail_1.4_spec</artifactId>
</exclusion>
<exclusion>
<groupId>org.apache.geronimo.specs</groupId>
<artifactId>geronimo-activation_1.1_spec</artifactId>
</exclusion>
</exclusions>
</dependency>
<!-- Because of a design flaw in Axis2 (see AXIS2-4265), axis2-codegen is required
to deploy some modules => include this explicitly. -->
<dependency>
<groupId>org.apache.axis2</groupId>
<artifactId>axis2-codegen</artifactId>
</dependency>
<!-- Additional transports -->
<dependency>
<groupId>org.apache.axis2</groupId>
<artifactId>axis2-transport-jms</artifactId>
</dependency>
<dependency>
<groupId>org.apache.axis2</groupId>
<artifactId>axis2-transport-mail</artifactId>
</dependency>
<dependency>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-vfs-transport</artifactId>
</dependency>
<dependency>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-fix-transport</artifactId>
<version>${pom.version}</version>
<exclusions>
<exclusion>
<groupId>quickfixj</groupId>
<artifactId>quickfixj-all</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>com.oopsconsultancy</groupId>
<artifactId>xmltask</artifactId>
<version>1.14</version>
</dependency>
<!-- Patches -->
<dependency>
<groupId>org.apache.synapse</groupId>
<artifactId>synapse-patches</artifactId>
<version>${pom.version}</version>
<classifier>jars</classifier>
<type>zip</type>
</dependency>
<dependency>
<groupId>org.apache.sandesha2</groupId>
<artifactId>sandesha2-policy</artifactId>
<version>${sandesha2.version}</version>
<exclusions>
<exclusion>
<groupId>org.apache.axis2</groupId>
<artifactId>axis2</artifactId>
</exclusion>
</exclusions>
</dependency>
</dependencies>
<repositories>
<!-- This is for xmltask -->
<repository>
<id>atlassian-developer-site</id>
<name>Atlassian Maven 2 Contributor Repository</name>
<url>http://maven.atlassian.com/repository/public</url>
<releases>
<enabled>true</enabled>
</releases>
<snapshots>
<enabled>false</enabled>
</snapshots>
</repository>
</repositories>
<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-assembly-plugin</artifactId>
<version>2.2-beta-2</version>
<executions>
<execution>
<id>distribution-package</id>
<phase>package</phase>
<goals>
<goal>single</goal>
</goals>
<configuration>
<descriptors>
<descriptor>src/main/assembly/bin.xml</descriptor>
<descriptor>src/main/assembly/src.xml</descriptor>
</descriptors>
<finalName>synapse-${synapse.version}</finalName>
</configuration>
</execution>
</executions>
</plugin>
</plugins>
</build>
</project>