SLING-8516 Make testing compliant with Java 9 and higher

* Use Sling Bundle Parent 35
* Update Pax Exam to 4.13.1
* Update Testing PaxExam to 3.0.0
* Update Felix Framework to 6.0.3
diff --git a/pom.xml b/pom.xml
index 0fb0daa..1f33e2d 100644
--- a/pom.xml
+++ b/pom.xml
@@ -23,8 +23,8 @@
 
   <parent>
     <groupId>org.apache.sling</groupId>
-    <artifactId>sling</artifactId>
-    <version>34</version>
+    <artifactId>sling-bundle-parent</artifactId>
+    <version>35</version>
     <relativePath/>
   </parent>
 
@@ -38,7 +38,7 @@
     <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
     <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
     <sling.java.version>8</sling.java.version>
-    <org.ops4j.pax.exam.version>4.12.0</org.ops4j.pax.exam.version>
+    <org.ops4j.pax.exam.version>4.13.1</org.ops4j.pax.exam.version>
   </properties>
 
   <scm>
@@ -84,7 +84,7 @@
       </plugin>
       <plugin>
         <groupId>org.apache.sling</groupId>
-        <artifactId>maven-sling-plugin</artifactId>
+        <artifactId>sling-maven-plugin</artifactId>
         <configuration>
           <slingUrl>http://localhost:8181/system/console</slingUrl>
           <user>karaf</user>
@@ -136,7 +136,7 @@
     <dependency>
       <groupId>org.apache.felix</groupId>
       <artifactId>org.apache.felix.framework</artifactId>
-      <version>5.6.10</version>
+      <version>6.0.3</version>
       <scope>test</scope>
     </dependency>
     <!-- Apache Sling -->
@@ -149,7 +149,7 @@
     <dependency>
       <groupId>org.apache.sling</groupId>
       <artifactId>org.apache.sling.testing.paxexam</artifactId>
-      <version>2.0.0</version>
+      <version>3.0.0</version>
       <scope>test</scope>
     </dependency>
     <!-- nullability -->