Add version requirement according API requirement (#15)

1 file changed
tree: f6f48385a5c1395bf43a0ea67413b328a1628051
  1. .asf.yaml
  2. .github/
  3. .gitignore
  4. .licenserc.yaml
  5. .luacheckrc
  6. .mvn/
  7. CHANGES.md
  8. LICENSE
  9. Makefile
  10. NOTICE
  11. README.md
  12. kong/
  13. mvnw
  14. mvnw.cmd
  15. release.md
  16. rockspec/
  17. test/
README.md

Apache SkyWalking Kong Agent

Twitter Follow

CI AND IT

SkyWalking Kong agent built on SkyWalking Nginx Lua agent to trace Kong API gateway for Apache SkyWalking APM.

Usage

Kong 2.2+ required.

  1. Install the plugin in Kong:

Install kong-plugin-skywalking using luarocks:

$ luarocks install kong-skywalking --local

Edit kong.conf:

plugins = bundled,skywalking

lua_package_path = ${user.home}/.luarocks/share/lua/5.1/?.lua;;

Set environment:

$ export KONG_NGINX_HTTP_LUA_SHARED_DICT="tracing_buffer 128m"

Restart Kong

  1. Enabling & configuring plugin:

Add the plugin to global:

$ curl -X POST --url http://localhost:8001/plugins/ \
   --data 'name=skywalking' \
   --data 'config.backend_http_uri=http://localhost:12800' \
   --data 'config.sample_ratio=100' \
   --data 'config.service_name=kong' \
   --data 'config.service_instance_name=kong-with-skywalking'

Contact Us

  • Submit an issue with [KONG] as the issue title prefix.
  • Mail list: dev@skywalking.apache.org. Mail to dev-subscribe@skywalking.apache.org, follow the reply to subscribe the mail list.
  • Join skywalking channel at Apache Slack. If the link is not working, find the latest one at Apache INFRA WIKI.
  • QQ Group: 392443393(2000/2000, not available), 901167865(available)

Release Guide

All committers should follow Release Guide to publish the official release.

License

Apache 2.0