blob: efc50c2bbf868a5fbaf2e966e985b90ba704b08c [file] [log] [blame]
{
"containers": {
"cna": {
"affected": [
{
"product": "Apache XMLBeans",
"vendor": "Apache Software Foundation",
"versions": [
{
"lessThanOrEqual": "2.6.0",
"status": "affected",
"version": "Apache XMLBeans",
"versionType": "custom"
}
]
}
],
"descriptions": [
{
"lang": "en",
"value": "The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks.\nAffects XMLBeans up to and including v2.6.0."
}
],
"problemTypes": [
{
"descriptions": [
{
"description": "Information Disclosure",
"lang": "en",
"type": "text"
}
]
}
],
"providerMetadata": {
"orgId": "Not found",
"shortName": "Not found"
},
"references": [
{
"tags": [
"x_refsource_CONFIRM"
],
"url": "https://poi.apache.org/"
},
{
"tags": [
"third-party-advisory",
"x_refsource_ISS"
],
"url": "https://issues.apache.org/jira/browse/XMLBEANS-517"
}
],
"source": {
"defect": [
"https://issues.apache.org/jira/browse/XMLBEANS-517"
],
"discovery": "UNKNOWN"
},
"title": "XMLBeans XML Entity Expansion",
"x_ValidationErrors": [
"$.cveMetadata.assignerOrgId -- validator = pattern",
"$.containers.cna.providerMetadata.orgId -- validator = pattern"
],
"x_generator": {
"engine": "Vulnogram 0.0.9"
},
"x_legacyV4Record": {
"CNA_private": {
"CVE_list": [],
"CVE_table_description": [],
"email": "fanningpj@apache.org",
"internal_comments": "",
"owner": "poi",
"publish": {
"month": "",
"year": "",
"ym": ""
},
"share_with_CVE": true,
"todo": []
},
"CVE_data_meta": {
"AKA": "",
"ASSIGNER": "security@apache.org",
"DATE_PUBLIC": "",
"ID": "CVE-2021-23926",
"STATE": "PUBLIC",
"TITLE": "XMLBeans XML Entity Expansion"
},
"affects": {
"vendor": {
"vendor_data": [
{
"product": {
"product_data": [
{
"product_name": "Apache XMLBeans",
"version": {
"version_data": [
{
"platform": "",
"version_affected": "<=",
"version_name": "Apache XMLBeans",
"version_value": "2.6.0"
}
]
}
}
]
},
"vendor_name": "Apache Software Foundation"
}
]
}
},
"configuration": [],
"credit": [],
"data_format": "MITRE",
"data_type": "CVE",
"data_version": "4.0",
"description": {
"description_data": [
{
"lang": "eng",
"value": "The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks.\nAffects XMLBeans up to and including v2.6.0."
}
]
},
"exploit": [],
"generator": {
"engine": "Vulnogram 0.0.9"
},
"impact": {},
"problemtype": {
"problemtype_data": [
{
"description": [
{
"lang": "eng",
"value": "Information Disclosure"
}
]
}
]
},
"references": {
"reference_data": [
{
"name": "",
"refsource": "CONFIRM",
"url": "https://poi.apache.org/"
},
{
"name": "",
"refsource": "ISS",
"url": "https://issues.apache.org/jira/browse/XMLBEANS-517"
}
]
},
"solution": [],
"source": {
"advisory": "",
"defect": [
"https://issues.apache.org/jira/browse/XMLBEANS-517"
],
"discovery": "UNKNOWN"
},
"work_around": []
}
}
},
"cveMetadata": {
"assignerOrgId": "Not found",
"assignerShortName": "Not found",
"cveId": "CVE-2021-23926",
"state": "PUBLISHED"
},
"dataType": "CVE_RECORD",
"dataVersion": "5.0"
}