blob: c908456d6dab5cd831269459daa0aecda30ee557 [file] [log] [blame]
{
"containers": {
"cna": {
"affected": [
{
"product": "Apache Kylin",
"vendor": "Apache Software Foundation",
"versions": [
{
"lessThan": "2.6.6",
"status": "affected",
"version": "Apache Kylin 2",
"versionType": "custom"
},
{
"lessThanOrEqual": "3.1.2",
"status": "affected",
"version": "Apache Kylin 3",
"versionType": "custom"
},
{
"lessThanOrEqual": "4.0.1",
"status": "affected",
"version": "Apache Kylin 4",
"versionType": "custom"
}
]
}
],
"credits": [
{
"lang": "en",
"value": "Kylin Team would like to thanks Kai Zhao of ToTU Secruity Team."
}
],
"descriptions": [
{
"lang": "en",
"value": "Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of \u201c-- conf=\u201d to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier."
}
],
"metrics": [
{
"other": {
"content": {
"other": "important"
},
"type": "unknown"
}
}
],
"problemTypes": [
{
"descriptions": [
{
"description": "Command injection",
"lang": "en",
"type": "text"
}
]
}
],
"providerMetadata": {
"orgId": "Not found",
"shortName": "Not found"
},
"references": [
{
"tags": [
"x_refsource_CONFIRM"
],
"url": "https://lists.apache.org/thread/07mnn9c7o314wrhrwjr10w9j5s82voj4"
}
],
"source": {
"discovery": "UNKNOWN"
},
"title": "Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters",
"workarounds": [
{
"lang": "en",
"value": "Users of Kylin 2.x & Kylin 3.x & 4.x should upgrade to 4.0.2 or apply patch https://github.com/apache/kylin/pull/1811 ."
}
],
"x_ValidationErrors": [
"$.cveMetadata.assignerOrgId -- validator = pattern",
"$.containers.cna.providerMetadata.orgId -- validator = pattern"
],
"x_generator": {
"engine": "Vulnogram 0.0.9"
},
"x_legacyV4Record": {
"CNA_private": {
"CVE_list": [],
"CVE_table_description": [],
"email": "",
"emailed": "yes",
"internal_comments": "",
"owner": "kylin",
"publish": {
"month": "",
"year": "",
"ym": ""
},
"share_with_CVE": true,
"todo": [],
"userslist": "dev@kylin.apache.org"
},
"CVE_data_meta": {
"AKA": "",
"ASSIGNER": "security@apache.org",
"DATE_PUBLIC": "",
"ID": "CVE-2022-24697",
"STATE": "PUBLIC",
"TITLE": "Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters"
},
"affects": {
"vendor": {
"vendor_data": [
{
"product": {
"product_data": [
{
"product_name": "Apache Kylin",
"version": {
"version_data": [
{
"platform": "",
"version_affected": "<",
"version_name": "Apache Kylin 2",
"version_value": "2.6.6"
},
{
"platform": "",
"version_affected": "<=",
"version_name": "Apache Kylin 3",
"version_value": "3.1.2"
},
{
"platform": "",
"version_affected": "<=",
"version_name": "Apache Kylin 4",
"version_value": "4.0.1"
}
]
}
}
]
},
"vendor_name": "Apache Software Foundation"
}
]
}
},
"configuration": [],
"credit": [
{
"lang": "eng",
"value": "Kylin Team would like to thanks Kai Zhao of ToTU Secruity Team."
}
],
"data_format": "MITRE",
"data_type": "CVE",
"data_version": "4.0",
"description": {
"description_data": [
{
"lang": "eng",
"value": "Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of \u201c-- conf=\u201d to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier."
}
]
},
"exploit": [],
"generator": {
"engine": "Vulnogram 0.0.9"
},
"impact": [
{
"other": "important"
}
],
"problemtype": {
"problemtype_data": [
{
"description": [
{
"lang": "eng",
"value": "Command injection"
}
]
}
]
},
"references": {
"reference_data": [
{
"name": "",
"refsource": "CONFIRM",
"url": "https://lists.apache.org/thread/07mnn9c7o314wrhrwjr10w9j5s82voj4"
}
]
},
"solution": [],
"source": {
"advisory": "",
"defect": [],
"discovery": "UNKNOWN"
},
"timeline": [],
"work_around": [
{
"lang": "en",
"value": "Users of Kylin 2.x & Kylin 3.x & 4.x should upgrade to 4.0.2 or apply patch https://github.com/apache/kylin/pull/1811 ."
}
]
}
}
},
"cveMetadata": {
"assignerOrgId": "Not found",
"assignerShortName": "Not found",
"cveId": "CVE-2022-24697",
"state": "PUBLISHED"
},
"dataType": "CVE_RECORD",
"dataVersion": "5.0"
}