blob: 0a915bd374bde5c596fa7ca1b536b757d63cef58 [file] [log] [blame]
{
"containers": {
"cna": {
"affected": [
{
"product": "Apache Kylin",
"vendor": "Apache Software Foundation",
"versions": [
{
"status": "affected",
"version": "Apache Kylin 4 4.0.0"
}
]
}
],
"credits": [
{
"lang": "en",
"value": "Alvaro Munoz <pwntester@github.com>"
}
],
"descriptions": [
{
"lang": "en",
"value": "Apache kylin checks the legitimacy of the project before executing some commands with the project name passed in by the user. There is a mismatch between what is being checked and what is being used as the shell command argument in DiagnosisService. This may cause an illegal project name to pass the check and perform the following steps, resulting in a command injection vulnerability.\nThis issue affects Apache Kylin 4.0.0."
}
],
"metrics": [
{
"other": {
"content": {
"other": "moderate"
},
"type": "unknown"
}
}
],
"problemTypes": [
{
"descriptions": [
{
"description": "Command injection",
"lang": "en",
"type": "text"
}
]
}
],
"providerMetadata": {
"orgId": "Not found",
"shortName": "Not found"
},
"references": [
{
"tags": [
"x_refsource_CONFIRM"
],
"url": "https://lists.apache.org/thread/70fkf9w1swt2cqdcz13rwfjvblw1fcpf"
}
],
"source": {
"discovery": "UNKNOWN"
},
"title": "Command injection",
"workarounds": [
{
"lang": "en",
"value": "Users of Kylin 4.0.0 should upgrade to 4.0.1 or apply patch https://github.com/apache/kylin/pull/1781."
}
],
"x_ValidationErrors": [
"$.cveMetadata.assignerOrgId -- validator = pattern",
"$.containers.cna.providerMetadata.orgId -- validator = pattern"
],
"x_generator": {
"engine": "Vulnogram 0.0.9"
},
"x_legacyV4Record": {
"CNA_private": {
"CVE_list": [],
"CVE_table_description": [],
"email": "",
"emailed": "",
"internal_comments": "",
"owner": "kylin",
"publish": {
"month": "",
"year": "",
"ym": ""
},
"share_with_CVE": true,
"todo": [],
"userslist": "dev@undefined.apache.org"
},
"CVE_data_meta": {
"AKA": "",
"ASSIGNER": "security@apache.org",
"DATE_PUBLIC": "",
"ID": "CVE-2021-45456",
"STATE": "PUBLIC",
"TITLE": "Command injection"
},
"affects": {
"vendor": {
"vendor_data": [
{
"product": {
"product_data": [
{
"product_name": "Apache Kylin",
"version": {
"version_data": [
{
"platform": "",
"version_affected": "=",
"version_name": "Apache Kylin 4",
"version_value": "4.0.0"
}
]
}
}
]
},
"vendor_name": "Apache Software Foundation"
}
]
}
},
"configuration": [],
"credit": [
{
"lang": "eng",
"value": "Alvaro Munoz <pwntester@github.com>"
}
],
"data_format": "MITRE",
"data_type": "CVE",
"data_version": "4.0",
"description": {
"description_data": [
{
"lang": "eng",
"value": "Apache kylin checks the legitimacy of the project before executing some commands with the project name passed in by the user. There is a mismatch between what is being checked and what is being used as the shell command argument in DiagnosisService. This may cause an illegal project name to pass the check and perform the following steps, resulting in a command injection vulnerability.\nThis issue affects Apache Kylin 4.0.0."
}
]
},
"exploit": [],
"generator": {
"engine": "Vulnogram 0.0.9"
},
"impact": [
{
"other": "moderate"
}
],
"problemtype": {
"problemtype_data": [
{
"description": [
{
"lang": "eng",
"value": "Command injection"
}
]
}
]
},
"references": {
"reference_data": [
{
"name": "",
"refsource": "CONFIRM",
"url": "https://lists.apache.org/thread/70fkf9w1swt2cqdcz13rwfjvblw1fcpf"
}
]
},
"solution": [],
"source": {
"advisory": "",
"defect": [],
"discovery": "UNKNOWN"
},
"timeline": [],
"work_around": [
{
"lang": "en",
"value": "Users of Kylin 4.0.0 should upgrade to 4.0.1 or apply patch https://github.com/apache/kylin/pull/1781."
}
]
}
}
},
"cveMetadata": {
"assignerOrgId": "Not found",
"assignerShortName": "Not found",
"cveId": "CVE-2021-45456",
"state": "PUBLISHED"
},
"dataType": "CVE_RECORD",
"dataVersion": "5.0"
}