blob: e2429fe1bb0c907f09a4fcaf5dd0a2951bf65e2f [file] [log] [blame]
{
"containers": {
"cna": {
"affected": [
{
"product": "Apache Dubbo",
"vendor": "Apache Software Foundation",
"versions": [
{
"lessThan": "2.7.15",
"status": "affected",
"version": "Apache Dubbo 2.7.x",
"versionType": "custom"
},
{
"lessThanOrEqual": "2.6.12",
"status": "affected",
"version": "Apache Dubbo 2.6.x",
"versionType": "custom"
}
]
}
],
"descriptions": [
{
"lang": "en",
"value": "bypass CVE-2021-25640 \n\n> In Apache Dubbo prior to 2.6.12 and 2.7.15, the usage of parseURL method will lead to the bypass of the white host check which can cause open redirect or SSRF vulnerability."
}
],
"problemTypes": [
{
"descriptions": [
{
"cweId": "CWE-918",
"description": "bypass CVE-2021-25640 (CWE-918 Server-Side Request Forgery (SSRF))",
"lang": "en",
"type": "CWE"
}
]
}
],
"providerMetadata": {
"orgId": "Not found",
"shortName": "Not found"
},
"references": [
{
"tags": [
"x_refsource_CONFIRM"
],
"url": "https://lists.apache.org/thread/1xbckc3467wfk5r7n2o44r2brdsbwxgr"
}
],
"source": {
"discovery": "UNKNOWN"
},
"title": "bypass of CVE-2021-25640",
"x_ValidationErrors": [
"$.cveMetadata.assignerOrgId -- validator = pattern",
"$.containers.cna.providerMetadata.orgId -- validator = pattern"
],
"x_generator": {
"engine": "Vulnogram 0.0.9"
},
"x_legacyV4Record": {
"CNA_private": {
"CVE_list": [],
"CVE_table_description": [],
"email": "",
"emailed": "",
"internal_comments": "",
"owner": "dubbo",
"publish": {
"month": "",
"year": "",
"ym": ""
},
"share_with_CVE": true,
"todo": [],
"userslist": ""
},
"CVE_data_meta": {
"AKA": "",
"ASSIGNER": "security@apache.org",
"DATE_PUBLIC": "",
"ID": "CVE-2022-24969",
"STATE": "PUBLIC",
"TITLE": "bypass of CVE-2021-25640"
},
"affects": {
"vendor": {
"vendor_data": [
{
"product": {
"product_data": [
{
"product_name": "Apache Dubbo",
"version": {
"version_data": [
{
"platform": "",
"version_affected": "<",
"version_name": "Apache Dubbo 2.7.x",
"version_value": "2.7.15"
},
{
"platform": "",
"version_affected": "<=",
"version_name": "Apache Dubbo 2.6.x",
"version_value": "2.6.12"
}
]
}
}
]
},
"vendor_name": "Apache Software Foundation"
}
]
}
},
"configuration": [],
"credit": [],
"data_format": "MITRE",
"data_type": "CVE",
"data_version": "4.0",
"description": {
"description_data": [
{
"lang": "eng",
"value": "bypass CVE-2021-25640 \n\n> In Apache Dubbo prior to 2.6.12 and 2.7.15, the usage of parseURL method will lead to the bypass of the white host check which can cause open redirect or SSRF vulnerability."
}
]
},
"exploit": [],
"generator": {
"engine": "Vulnogram 0.0.9"
},
"impact": [
{
"other": ""
}
],
"problemtype": {
"problemtype_data": [
{
"description": [
{
"lang": "eng",
"value": "bypass CVE-2021-25640 (CWE-918 Server-Side Request Forgery (SSRF))"
}
]
}
]
},
"references": {
"reference_data": [
{
"name": "",
"refsource": "CONFIRM",
"url": "https://lists.apache.org/thread/1xbckc3467wfk5r7n2o44r2brdsbwxgr"
}
]
},
"solution": [],
"source": {
"advisory": "",
"defect": [],
"discovery": "UNKNOWN"
},
"timeline": [],
"work_around": []
}
}
},
"cveMetadata": {
"assignerOrgId": "Not found",
"assignerShortName": "Not found",
"cveId": "CVE-2022-24969",
"state": "PUBLISHED"
},
"dataType": "CVE_RECORD",
"dataVersion": "5.0"
}