SAMZA-2616: Upgrade ZK Client. (#1456)

Issues: The current ZK Client versions are very old and contain security risks and bugs that have been fixed with newer versions of the libraries Samza uses. The current ZKClient library we use stops at 0.11 therefore any newer version of Zookeeper is a much bigger change. This upgrades to the latest version to improve Samza with minimal disruption.

Changes: Describe major changes, listing each separately.
1. Upgrade Zookeeper version 3.4.13
2. Upgrade ZKClient version to 0.11
diff --git a/gradle/dependency-versions.gradle b/gradle/dependency-versions.gradle
index 60e7766..e05b837 100644
--- a/gradle/dependency-versions.gradle
+++ b/gradle/dependency-versions.gradle
@@ -48,8 +48,8 @@
   scalaTestVersion = "3.0.1"
   slf4jVersion = "1.7.7"
   yarnVersion = "2.7.1"
-  zkClientVersion = "0.8"
-  zookeeperVersion = "3.4.6"
+  zkClientVersion = "0.11"
+  zookeeperVersion = "3.4.13"
   failsafeVersion = "1.1.0"
   jlineVersion = "3.8.2"
   jnaVersion = "4.5.1"