Dockerfile in roller-6.0.x should build against roller-6.0.x.
diff --git a/Dockerfile b/Dockerfile
index 28570de..29410a2 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -31,7 +31,7 @@
 RUN apt-get update && apt-get install -y git
 RUN git clone https://github.com/apache/roller.git
 WORKDIR /tmp/roller
-RUN git checkout master; \
+RUN git checkout roller-6.0.x; \
 mvn -Duser.home=/builder/home -DskipTests=true -B clean install