Allow building Apache Pulsar on JDK15+ - upgrade Maven Assembly Plugin (#8360)

Motivation
Currently Pulsar does not build on JDK15

Modifications
update Maven Assembly plugin
move maven-git-commit-id plugin execution only inside Pulsar Common (in order to speed up the build)
upgrading the Maven Assembly Plugin resulted in a different output for the "binaries", I had to update license files
forced version of Jersey to 2.31 in "Presto" distribution (otherwise the license check failed, because it does not handle different versions between main pulsar binaries and presto distribution inside lib/presto/lib, and this makes sense to me)
Verifying this change
This change is already covered by existing tests


* Allow to build Pulsar on JDK14+
- update Apache Maven Assembly Plugin
- use explicit import for Record class (prevent clash with java.lang.Record)

* revert Apache pom update

* fix

* Fix presto distribution - due to maven assembly plugin upgrade

* fix licenses

* Fix kafka clients

* fix LICENSE

Co-authored-by: Enrico Olivelli <enrico.olivelli@diennea.com>
Co-authored-by: Enrico Olivelli <eolivelli@apache.org>
diff --git a/distribution/server/src/assemble/LICENSE.bin.txt b/distribution/server/src/assemble/LICENSE.bin.txt
index 0f0ace0..fa6946e 100644
--- a/distribution/server/src/assemble/LICENSE.bin.txt
+++ b/distribution/server/src/assemble/LICENSE.bin.txt
@@ -371,7 +371,6 @@
     - io.netty-netty-transport-native-epoll-4.1.51.Final.jar
     - io.netty-netty-transport-native-unix-common-4.1.51.Final.jar
     - io.netty-netty-transport-native-unix-common-4.1.51.Final-linux-x86_64.jar
-    - io.netty-netty-transport-native-kqueue-4.1.51.Final-osx-x86_64.jar
     - io.netty-netty-tcnative-boringssl-static-2.0.30.Final.jar
  * Prometheus client
     - io.prometheus-simpleclient-0.5.0.jar
diff --git a/tests/pulsar-kafka-compat-client-test/src/test/java/org/apache/pulsar/tests/integration/compat/kafka/PulsarKafkaProducerThreadSafeTest.java b/tests/pulsar-kafka-compat-client-test/src/test/java/org/apache/pulsar/tests/integration/compat/kafka/PulsarKafkaProducerThreadSafeTest.java
index 1246b1d..e6e183a 100644
--- a/tests/pulsar-kafka-compat-client-test/src/test/java/org/apache/pulsar/tests/integration/compat/kafka/PulsarKafkaProducerThreadSafeTest.java
+++ b/tests/pulsar-kafka-compat-client-test/src/test/java/org/apache/pulsar/tests/integration/compat/kafka/PulsarKafkaProducerThreadSafeTest.java
@@ -21,7 +21,6 @@
 import org.apache.kafka.clients.producer.KafkaProducer;
 import org.apache.kafka.clients.producer.Producer;
 import org.apache.kafka.clients.producer.ProducerRecord;
-import org.apache.kafka.clients.producer.PulsarKafkaProducer;
 import org.apache.kafka.common.serialization.IntegerSerializer;
 import org.apache.kafka.common.serialization.StringSerializer;
 import org.apache.pulsar.tests.integration.suites.PulsarStandaloneTestSuite;