Upgrade solr version to 8.6.3 (#8328)

Signed-off-by: xiaolong.ran <rxl@apache.org>


Fixes #8324 


### Motivation

In Apache Solr 8.6.0, there are the following security issues:

- CVE-2020-13957

Recommended upgrade version´╝Ü8.6.3

### Modifications

- Upgrade solr version to `8.6.3`
1 file changed
tree: d3d1489d009a6307544ce78e6e0ad16eadd857b4
  1. pulsar-io/