Tag 2.6
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEnQpWqqDWDgwMfczAtMcIk7Yrq+gFAl8ovtUACgkQtMcIk7Yr
q+jo5Q/9F9YnjzfNpyHMZW1G/QSO/2d0vqhGn29p0mGk/yPoOX8XCWPAIvkZu296
98J5ANBa86l03QtCAncD+F/fiNYk7Pqj4NVMvBv6rFz38C8S77GiOztSrNvxCBsz
zxGOIn1mW4Aa0wHcZExa/jw1XAwG8r/hFy4pY7MU4UpddkDYHufjfU77iW4tTbaa
gMFtIxCsMFPACPv6zFYQFv6SCS2gkwlPghrWF2O4caYPPgUXSwcGg8ayXMfoauza
/tZAUMRGanjyjqxFpim2N46vnPvCT0/JSalxU3Mj/RErCfImVdGLj9KkdyZSRxnW
u4cU1Eagh7gbVbs4TKTbyq2ZwYu8pv/8DnhJJLO0fSpcR6vc/N61KBoCkUNXSCLr
mm0Cw2i6AQ+a93k7S40OFbcVkzeUisi3AN0S7WoIa4Jd/m+nQUXRm9vhPCetrgw5
QJfxOnBmfDQ0UqciITqAKIQn1PPya/1BjBKEbXkUTPe/zjHnDu5BAsxLrwKzxZbO
H/Yybpn8LtPS2q1r09ngM4g/b/MlxFHTpzGaQi8gMh2bIWyrSsm1dLGlEoJw4Okv
8UNqSpiJeQJ1v4NdawdpBe/Ahu3Gyu/9Xcq9LvjaZJho+v/Gwm0zauzVzbP48POw
JQhcQ/+Z2HNToEj1IkKUzFv7VHhqGJCPq/7IKLAV+cf1FjsujsM=
=Tq6H
-----END PGP SIGNATURE-----
[maven-release-plugin] prepare release log4j-2.6-rc1
24 files changed
tree: a28ff61a6cb9dee142f0525470b2e36e7054e20c
  1. .gitignore
  2. BUILDING.txt
  3. LICENSE.txt
  4. NOTICE.txt
  5. README.md
  6. RELEASE-NOTES.txt
  7. Vagrantfile
  8. checkstyle-header.txt
  9. checkstyle-import-control.xml
  10. checkstyle-suppressions.xml
  11. checkstyle.xml
  12. doap_log4j2.rdf
  13. findbugs-exclude-filter.xml
  14. log4j-1.2-api/
  15. log4j-api/
  16. log4j-bom/
  17. log4j-core/
  18. log4j-distribution/
  19. log4j-flume-ng/
  20. log4j-iostreams/
  21. log4j-jcl/
  22. log4j-jmx-gui/
  23. log4j-jul/
  24. log4j-liquibase/
  25. log4j-nosql/
  26. log4j-perf/
  27. log4j-samples/
  28. log4j-slf4j-impl/
  29. log4j-taglib/
  30. log4j-to-slf4j/
  31. log4j-web/
  32. pom.xml
  33. src/
README.md

Apache Log4j 2

Apache Log4j 2 is an upgrade to Log4j that provides significant improvements over its predecessor, Log4j 1.x, and provides many of the improvements available in Logback while fixing some inherent problems in Logback's architecture.

Documentation

The Log4j 2 User's Guide is available here or as a downloadable PDF.

Requirements

Log4j 2.4 and greater requires Java 7, versions 2.0-alpha1 to 2.3 required Java 6. Some features require optional dependencies; the documentation for these features specifies the dependencies.

License

Apache Log4j 2 is distributed under the Apache License, version 2.0.

Download

How to download Log4j, and how to use it from Maven, Ivy and Gradle.