Apache Apisix

Clone this repo:
  1. 329b092 feature: add object property editor (#170) by bzp2010 · 7 weeks ago master
  2. fbb6315 feature: add array property editor (#167) by bzp2010 · 7 weeks ago
  3. cfb3ee7 feature:allow set filter_func in router configuation page (#164) by chaofa · 9 weeks ago
  4. df4c6be feature:allow set vars filter in router configuration page (#160) by chaofa · 9 weeks ago
  5. b3045dd add inbuilt hamburger icon. (#135) by Ayeshmantha Perera · 3 months ago

apisix_dashboard

Overview

Dashboard for APISIX & based on ElementUI.

Documentation

Docs

Vue Config Docs

Project Structure

├── public                     # public static assets
   │── img/                   # static image files
   │── favicon.ico            # favicon
   │── index.html             # index.html template
   └── robots.txt             # robots file
├── src                        # main source code
   ├── api/                   # api service
   ├── components/            # global components
   ├── lang/                  # i18n language
   ├── layout/                # global layout
   ├── router/                # router
   ├── store/                 # store
   ├── styles/                # global css
   ├── utils/                 # global utils
   ├── views/                 # views
   ├── App.vue                # main app component
   ├── main.ts                # app entry file
   ├── permission.ts          # permission authentication
   ├── settings.ts            # setting file
   └── shims.d.ts             # type definition shims
├── licenses                   # license files for ALv2 and boilerplate
├── .browserslistrc            # browserslist config file (to support Autoprefixer)
├── .editorconfig              # editor code format consistency config
├── .env.xxx                   # env variable configuration
├── .eslintrc.js               # eslint config
├── .eslintignore              # eslint ignore config
├── .gitignore                 # git ignore config
├── babel.config.js            # babel config
├── LICENSE                    # license file
├── NOTICE                     # notice file
├── package.json               # package.json
├── postcss.config.js          # postcss config
├── README.md                  # some information about APISIX
├── tsconfig.json              # typescript config
├── vue.config.js              # vue-cli config
└── yarn.lock                  # keep exact versions of each dependency

Project setup

Make sure Node.js 8.12.0 or higher, and Yarn are installed on your machine: https://yarnpkg.com/en/docs/install

Install dependencies

yarn install

Compiles and hot-reloads for development

yarn run serve

Compiles and minifies for production

yarn run build:prod

Lints and fixes files

yarn run lint

Customize Vue configuration

See Configuration Reference.

Browsers support

Modern browsers and Internet Explorer 10+.

IE / EdgeFirefoxChromeSafari
IE10, IE11, Edgelast 2 versionslast 2 versionslast 2 versions