Sign in
◑
Theme
apache
/
httpcomponents-core
/
HEAD
63c0556
Filter control characters in encoded HTTP/1 output lines
by Arturo Bernal
· 4 days ago
master
fbf8ebd
AsyncH2SocketTimeoutCoreTest: Bind to `127.0.0.1` explicitly
by Ryan Schmitt
· 8 days ago
2d7160d
Upgraded HttpCore version to 5.5-beta5-SNAPSHOT
by Oleg Kalnichevski
· 11 days ago
c5c6dd6
Added RFC 9530 to the list of supported specifications
by Oleg Kalnichevski
· 2 weeks ago
34412fb
Updated release notes for HttpCore 5.5-beta4 release
by Oleg Kalnichevski
· 2 weeks ago
955dc54
Upgraded Testcontainers to version 2.0.5
by Oleg Kalnichevski
· 2 weeks ago
efcefb5
IOSessionImpl: update lastEventTime upon command submission
by Oleg Kalnichevski
· 2 weeks ago
a60d8e5
AbstractIOSessionPool: improved available sessions enumeration; improved session validation; added method to evict expired sessions
by Oleg Kalnichevski
· 3 weeks ago
4ca20a4
Use Mockito JUnit extension to wire tests with Mockito mocks
by Oleg Kalnichevski
· 2 weeks ago
711ef4f
IOSession: added session initiation time
by Oleg Kalnichevski
· 2 weeks ago
f476477
Removed testing framework unused and unmaintained since its contribution in 2016 (binary compatibility breakage)
by Oleg Kalnichevski
· 3 weeks ago
d6b7790
Correct handling of unsigned HTTP/2 SETTINGS values
by Arturo Bernal
· 4 weeks ago
5913abf
Improved handling of idle sessions by AbstractIOSessionPool / H2ConnPool
by Oleg Kalnichevski
· 3 weeks ago
89508f9
Restore absolute millisecond timestamps in I/O reactor and H2
by Arturo Bernal
· 3 weeks ago
678b60c
AbstractHttp1StreamDuplexer should not trigger output interest when completion of a message leaves no data in the output buffer
by Oleg Kalnichevski
· 3 weeks ago
4c24974
Complete I/O reactor termination when the selector has been closed by another thread
by AdzerKI
· 3 weeks ago
44b4f47
Bump actions/cache from 5 to 6
by dependabot[bot]
· 3 weeks ago
521713f
Bump the all group across 1 directory with 5 updates
by dependabot[bot]
· 3 weeks ago
0b0a20e
Upgraded HC Parent to version 15 / POM cleanup
by Oleg Kalnichevski
· 3 weeks ago
ba0a125
Reject malformed HTTP/2 response headers
by Arturo Bernal
· 4 weeks ago
23e7f8e
HTTP/2: Correct pushed response message handling
by Arturo Bernal
· 3 weeks ago
7f2c8a3
Fail unprocessed local streams on GOAWAY
by Ariel Rodriguez
· 4 weeks ago
23dc933
Send RST_STREAM for a cancelled half-closed stream
by Ariel Rodriguez
· 4 weeks ago
4ead259
Mock wiring improvements and code cleanup in Mockito test cases
by Oleg Kalnichevski
· 4 weeks ago
04cbb2f
Fix H2 stream flow control overflow
by Arturo Bernal
· 4 weeks ago
814622c
Reject H2 DATA on reserved streams
by Arturo Bernal
· 4 weeks ago
5aa2898
Optimize message list traversal
by Arturo Bernal
· 4 weeks ago
c036388
Added #isIdle method to async HTTP/1.1 and HTTP/2 protocol handlers to test if there are ongoing messages exchanges or the handlers can be considered idle
by Oleg Kalnichevski
· 4 weeks ago
a2b27ad
Improved the endpoint release logic in HttpAsyncRequester
by Oleg Kalnichevski
· 4 weeks ago
b3e62a8
Removed unnecessary global pool lock in AbstractIOSessionPool
by Oleg Kalnichevski
· 4 weeks ago
41f059f
Optimize HPACK full match lookup
by Arturo Bernal
· 4 weeks ago
4d9f231
Limit HPACK encoder table size
by Arturo Bernal
· 4 weeks ago
a1807c4
Fix HPACK encoder buffer expansion for multibyte values.
by Arturo Bernal
· 4 weeks ago
e91fc9c
Added H2MultiplexingRequester method to evict expired connections
by Oleg Kalnichevski
· 4 weeks ago
b1cc3b6
Removed the initial implementation of #closeIdle in H2MultiplexingRequester as it can cause premature termination of sessions with multiplexing message exchanges
by Oleg Kalnichevski
· 4 weeks ago
d6a56e0
Improve HPACK decoding conformance.
by Arturo Bernal
· 4 weeks ago
25775fe
Optimize HPACK Huffman decoding with a byte-oriented DFA.
by Arturo Bernal
· 4 weeks ago
55dafb0
RFC 9530 Digest Fields support
by Arturo Bernal
· 4 weeks ago
1dd0a8e
Async requesters to propagate message exchange #outputAborted() event
by Oleg Kalnichevski
· 4 weeks ago
113e78d
Limit write chunk size in IOSessionImpl
by yhzdys
· 4 weeks ago
575f66a
Bump actions/setup-java from 5 to 6
by dependabot[bot]
· 8 weeks ago
0c44b9b
Disable javadoc missing tag warning
by Oleg Kalnichevski
· 4 weeks ago
6ba8666
Upgraded HttpCore version to 5.5-beta4-SNAPSHOT
by Oleg Kalnichevski
· 4 weeks ago
636033d
Javadoc fixes
by Oleg Kalnichevski
· 5 weeks ago
53513fc
Async data exchnage handlers to signal that the opposite endpoint requesed graceful outgoing data stream termination
by Oleg Kalnichevski
· 5 weeks ago
acb5ce3
Revise release notes for 5.5-beta3
by Gary Gregory
· 5 weeks ago
02c785b
Updated release notes for HttpCore 5.5-beta3 release
by Oleg Kalnichevski
· 5 weeks ago
06365b7
HTTPCORE-800: Fix hexadecimal encoding of control characters
by Arturo Bernal
· 5 weeks ago
2bcbbed
RFC10015 support in TlsCiphers (#686)
by Gary Gregory
· 5 weeks ago
e99e078
HTTPCORE-799: Reset async entity producer state after interrupted writes
by Matthias Kurz
· 5 weeks ago
0863485
RFC 9651: Structured Field Values for HTTP
by Arturo Bernal
· 7 weeks ago
2ee2a73
Fix URIBuilder encoding policy documentation and null reset
by Praful Gupta
· 6 weeks ago
4021b98
#parseElementList in MessageSupport to tolerate trailing whitespace; #parseElementListStrict to disallow malformed / unparsed elements
by Oleg Kalnichevski
· 7 weeks ago
a73b9a1
Corrected the use of custom delimiters by #parseTokens in MessageSupport
by Oleg Kalnichevski
· 7 weeks ago
2fb1b78
Transfer-Encoding parsing optimization in DefaultContentLengthStrategy
by Oleg Kalnichevski
· 7 weeks ago
142a557
Header iterator memory optimization in HeaderGroup
by Oleg Kalnichevski
· 7 weeks ago
6e0fd20
MessageSupport: method for strict header value parsing
by Oleg Kalnichevski
· 6 weeks ago
2151715
MessageSupport: method for strict header value transformation
by Oleg Kalnichevski
· 6 weeks ago
d36bdf2
Fixed typo in method name
by Oleg Kalnichevski
· 6 weeks ago
3517685
Strict #parse methods in MessageSupport to throw ParseException
by Oleg Kalnichevski
· 6 weeks ago
9eb6c1f
PercentCodec decoder to disallow non-ASCII characters in input
by Oleg Kalnichevski
· 8 weeks ago
52e323c
HTTPCORE-798: Make socket channel creation customizable
by Arturo Bernal
· 9 weeks ago
e9fa304
Improved message exchange initation and endpoint management in HttpAsyncRequester
by Oleg Kalnichevski
· 9 weeks ago
a2d9e16
Parsing code optimization in PriorityParamsParser
by Oleg Kalnichevski
· 10 weeks ago
21994f9
HTTPCORE-797: fixed infinite recursion in SSLContexts#createDefault
by Oleg Kalnichevski
· 2 months ago
0b8f71a
Improved logic of HTTP/1.1 request termination: terminate the request in case of non-2xx reponse with 'Connecction: close'
by Oleg Kalnichevski
· 4 months ago
559e5f2
Use simplified toString() implementation to avoid possible deadlocks
by Andrey Turbanov
· 2 months ago
0decd82
Add Java 25 (LTS) to GH CI builds. (#685)
by Gary Gregory
· 2 months ago
1afc9b6
Bump actions/checkout from 6 to 7
by dependabot[bot]
· 3 months ago
c0a9274
Increase default HTTP/1.1 buffer size to 32 KiB
by Arturo Bernal
· 2 months ago
3d41a2d
Upgrade Conscrypt
by Ryan Schmitt
· 3 months ago
da423c9
Convert TestTlsCiphers to use @ParameterizedTest
by Gary Gregory
· 3 months ago
d019de5
H2 stream handlers to make sure content-length header value equals the sum of data payload as per RFC 9113, section 8.1.1
by Oleg Kalnichevski
· 3 months ago
ac59ee5
Migrate JSON bindings to Jackson 3
by Arturo Bernal
· 4 months ago
59e3848
H2 stream handler test improvements
by Oleg Kalnichevski
· 3 months ago
8f0308f
Deprecate EntityUtils#toByteArray / EntityUtils#toString methods with no maxResultLength constraint
by Oleg Kalnichevski
· 3 months ago
7f2f7b9
Document nullable IOSession return values
by Arturo Bernal
· 3 months ago
56c2d3d
Added #getContentLength method to MessageSupport
by Oleg Kalnichevski
· 3 months ago
9a044f0
Bump actions/dependency-review-action from 4 to 5
by dependabot[bot]
· 5 months ago
ffd0a43
Updated push branch declaration in maven.yml
by Oleg Kalnichevski
· 3 months ago
fcdb530
Restrict trigger push branch for GitHub Workflow
by Aurélien Pupier
· 4 months ago
c73e499
Upgraded HttpCore version to 5.5-beta3-SNAPSHOT
by Oleg Kalnichevski
· 4 months ago
c1ccbd3
Updated release notes for HttpCore 5.5-beta2 release
by Oleg Kalnichevski
· 4 months ago
e774783
Remove @Experimental for QUERY method and implement conformance to RFC 10008 (#673)
by Mario Daniel Ruiz Saavedra
· 4 months ago
0cbf3fc
HTTPCORE-796: abort redirected requests during the expect-continue handshake the same way as errors
by Oleg Kalnichevski
· 4 months ago
d21261e
SSLIOSession: Fix regression in backpressure handling
by Ryan Schmitt
· 4 months ago
fdc53a3
Use max line length of 8192 and max header count of 100 for incoming HTTP/1 messages by default
by Oleg Kalnichevski
· 4 months ago
cc30ee0
Enforce configured HPACK header list size limit on initialization
by Arturo Bernal
· 4 months ago
4a8a512
HTTPCORE-774: fixed a race condition caused by concurrent update of the connection input window to the max value.
by Oleg Kalnichevski
· 1 year, 10 months ago
8a3c5e6
Upgraded HttpCore version to 5.5-beta2-SNAPSHOT
by Arturo Bernal
· 5 months ago
bad74f0
Updated release notes for HttpCore 5.5-beta1 release
by Arturo Bernal
· 5 months ago
9a32d54
Upgraded project and website component URLs
by Oleg Kalnichevski
· 5 months ago
386189e
Optimization of ContentType parsing
by Oleg Kalnichevski
· 5 months ago
1b159d1
Added header value transformation method to MessageSupport
by Oleg Kalnichevski
· 5 months ago
2d52e37
Reduce contention and disposer back-pressure in RouteSegmentedConnPool. Lazy waiter-skip deque, skip enqueue/drain when no waiters, O(1) late-hit completion, and a properly sized timed-out disposer pool.
by Arturo Bernal
· 6 months ago
1212b84
Path segment codec APIs
by Oleg Kalnichevski
· 5 months ago
3369578
Set up default protection ruleset for release branches
by The Apache Software Foundation
· 5 months ago
ff9defb
Fix broken Maven central badge in `README`
by Jack Green
· 5 months ago
19802cf
Bump the all group across 1 directory with 6 updates
by dependabot[bot]
· 6 months ago
35e7d53
Configurable HTTP/2 PING ACK timeout
by Arturo Bernal
· 7 months ago
Next »