1. ef40283 do not hand system proxy credentials to the origin server by Mohammed Hassan · 15 hours ago master
  2. 430191f Jakarta REST client: do not produce '//' when base URI ends in '/' by Arturo Bernal · 28 hours ago
  3. c7e084f AutScope: added ChallengeType attribute by Oleg Kalnichevski · 5 days ago
  4. 82b3eef ProtocolExec, AsyncProtocolExec: extract path prefix lazily on demand; test coverage by Oleg Kalnichevski · 10 days ago
  5. 5d4215d Removed redundant @since tags (no functional changes) by Oleg Kalnichevski · 5 days ago
  6. 1e6bebb honor TlsConfig protocols and cipher suites in classic TLS upgrade by Mohammed Hassan · 8 days ago
  7. 3f68ba8 set cookie origin in RequestAddCookies when a Cookie header is present (#924) by Mohammed Hassan · 8 days ago
  8. 570a63d Keep request paths with dots inside segments on the fast path when extracting the path prefix by Parker Winchester · 10 days ago
  9. 10c5eaf SSE: report socket, connect and HTTP/1.1 and HTTP/2 stream timeouts through onFailure and reconnect by Arturo Bernal · 10 days ago
  10. b0bdae9 normalise spki pin pattern before wildcard validation by Javid Khan · 10 days ago
  11. 84ec7b8 strip trailing dot before matching spki pinning rules by Javid Khan · 3 weeks ago
  12. e040ff3 RequestSupport#extractPathPrefix optimization (regression) by Oleg Kalnichevski · 10 days ago
  13. 81e9b3a Bump actions/cache from 4 to 6 by dependabot[bot] · 10 days ago
  14. 5e06e3f Bump the all group across 1 directory with 8 updates by dependabot[bot] · 10 days ago
  15. 6335ff1 RequestSupport#extractPathPrefix optimization by Oleg Kalnichevski · 2 weeks ago
  16. 3a6bdbd SSE: bound the line length and the event size by Arturo Bernal · 13 days ago
  17. ad415f3 Moved request cancellation integration tests into separate groups to be executed manually during release preparation due to those tests failing intermittently in CI by Oleg Kalnichevski · 13 days ago
  18. d5415d4 Verify the TLS endpoint of an HTTPS proxy against the proxy host by Arturo Bernal · 13 days ago
  19. 154d4ac Do not treat a 407 received through a tunnel as a proxy challenge by Arturo Bernal · 13 days ago
  20. afb84da Do not skip hostname verification when the CLIENT policy has no verifier by Arturo Bernal · 13 days ago
  21. fbddce4 Use PrefixedIncrementingId for BasicHttpClientConnectionManager id by shinseongsu · 2 weeks ago
  22. fd25e8e reject redirect responses to CONNECT in (Async)ConnectExec by Mohammed Hassan · 2 weeks ago
  23. fc48584 TestGZip: assert writeTo propagates IOException by Sharang Gupta · 2 weeks ago
  24. c785279 TlsRequiredAsyncExec must not proceed down the exec chain after failing the exchange for a cleartext route by Arturo Bernal · 2 weeks ago
  25. 4cdc1d3 TestLinearBackoffManager: Re-enable probeUpdatesRemainingAttemptsIndirectly by Sharang Gupta · 2 weeks ago
  26. f3e886d reject dot-segment path parameters in RestInvocationHandler by Mohammed Hassan · 2 weeks ago
  27. 1890935 Keep the base path when a redirect location is only a query or a fragment (#904) by Wleeaf · 2 weeks ago
  28. cc1bf9a Reject cookies with control characters as invalid by Javid Khan · 3 weeks ago
  29. 67b0915 Upgrade brotli4j to 1.24.0 for CVE-2026-111497 by Donghun Ha · 3 weeks ago
  30. 378382d Fix SCRAM authentication lifecycle across consecutive requests by Arturo Bernal · 3 weeks ago
  31. ccc2391 Tighten RFC 7804 SCRAM message validation. by Arturo Bernal · 5 weeks ago
  32. e6cc976 Moved socket timeout integration tests to 'time-out' to be executed manually during release preparation due to those tests failing intermittently in CI by Oleg Kalnichevski · 3 weeks ago
  33. 1d0ae9b Upgraded HttpClient version to 5.7-beta2-SNAPSHOT by Oleg Kalnichevski · 3 weeks ago
  34. acb0cd3 Add RFC 9211 to the list of supported specifications by Arturo Bernal · 4 weeks ago
  35. 65f4ccd Explicitly bind to `127.0.0.1` in tests by Ryan Schmitt · 4 weeks ago
  36. e413d1d Fix spurious TCP resets when initiating TLS connection closure by Ryan Schmitt · 4 weeks ago
  37. 600e51f Review release notes for US English grammar and spelling. by Gary Gregory · 4 weeks ago
  38. 482820f Updated release notes for HttpClient 5.7 beta-1 release by Oleg Kalnichevski · 4 weeks ago
  39. 318bd31 Expire idle connections based on connection or request configuration and then evict them as expired. Deprecated #evictIdleConnections should not be used by Oleg Kalnichevski · 4 weeks ago
  40. 9411b3d Fixed Jackson deprecations by Oleg Kalnichevski · 4 weeks ago
  41. 4456b34 Always use maxResultLength constraint with EntityUtils#toByteArray and EntityUtils#toString by Oleg Kalnichevski · 4 weeks ago
  42. b3f6802 InternalH2ConnPool: support for ConnectionConfig connection life-cycle parameters (validateAfterInactivity, idleTimeout, timeToLive) by Oleg Kalnichevski · 5 weeks ago
  43. ddda928 Upgraded HttpCore to version 5.5-beta4 by Oleg Kalnichevski · 4 weeks ago
  44. 5a52fee require scram server nonce to extend the client nonce by Javid Khan · 5 weeks ago
  45. 9f7a05a Bump the all group across 1 directory with 10 updates by dependabot[bot] · 5 weeks ago
  46. 18f2961 Replaced System.out calls with logging in tests by Oleg Kalnichevski · 5 weeks ago
  47. 6681f28 Upgraded maven-surefire-plugin to the version defined in HC Parent by Oleg Kalnichevski · 5 weeks ago
  48. 83af126 Upgraded Testcontainers to version 2.0.5 by Oleg Kalnichevski · 5 weeks ago
  49. e37a0e3 Use Mockito JUnit extension to wire tests with Mockito mocks by Oleg Kalnichevski · 5 weeks ago
  50. 5a3138d SSE: Handle request header names case-insensitively by Arturo Bernal · 6 weeks ago
  51. fd21b1b SSE: Update Last-Event-ID independently of event dispatch by Arturo Bernal · 6 weeks ago
  52. 07bed09 SSE: Do not dispatch incomplete events at end of stream by Arturo Bernal · 6 weeks ago
  53. 4e59869 HTTPCLIENT-2429: Improve support for custom transport layers by Arturo Bernal · 3 months ago
  54. c8d231f route the first non-BOM byte through the CR/LF handling in ByteSseEntityConsumer by Javid Khan · 5 weeks ago
  55. 2e1320c treat a lone CR as an SSE line terminator by Javid Khan · 6 weeks ago
  56. 036cdaf Bump actions/checkout from 5 to 7 by dependabot[bot] · 6 weeks ago
  57. 90a7e77 Upgraded HC parent to version 15 / POM cleanup by Oleg Kalnichevski · 7 weeks ago
  58. 8b64f59 Removed the initial implementation of #evictIdleConnections in H2AsyncClientBuilder as it can cause premature termination of connections with multiplexing message exchanges; added #evictExpiredConnections to proactively evict expired connections from the connection pool by Oleg Kalnichevski · 7 weeks ago
  59. b8e9406 Disabled the keep-alive strategy for HTTP/2 connections as it contradicts RFC 9113, section 8.2.2. "Connection-Specific Header Fields"; updated relevant javadocs by Oleg Kalnichevski · 7 weeks ago
  60. 7d62d75 Disable javadoc missing tag warning by Oleg Kalnichevski · 7 weeks ago
  61. a2f45e9 Async exchange handlers to support #outputAborted event by Oleg Kalnichevski · 7 weeks ago
  62. 3423165 Auth challenge parsing improvements by Oleg Kalnichevski · 9 weeks ago
  63. 0e91503 Upgraded HttpCore to version 5.5-beta3 by Oleg Kalnichevski · 9 weeks ago
  64. 7cded0c HTTPCLIENT-2434 Deprecate idle connection eviction by Arturo Bernal · 8 weeks ago
  65. 20ea5c4 Bump actions/setup-java from 5 to 5.6.0 by dependabot[bot] · 3 months ago
  66. e8d667c Add RFC 7639 ALPN header codec; emit ALPN on CONNECT tunnels by Arturo Bernal · 1 year, 1 month ago
  67. 636993f Preserve idle timeout when copying connection configuration by Arturo Bernal · 8 weeks ago
  68. e750f52 Simplifcation of the message exchange handling logic in the main async exec interceptors by Oleg Kalnichevski · 8 weeks ago
  69. 3849cf9 HTTPCLIENT-2433: Prevent concurrent HTTP/2 request body replay by Matthias Kurz · 8 weeks ago
  70. 94be1b3 Improved connection expiry and eviction example by Oleg Kalnichevski · 8 weeks ago
  71. 6579979 Moved tls handshake timeout integration tests to 'time-out' to be executed manually during release preparation due to those tests failing intermittently in CI by Oleg Kalnichevski · 8 weeks ago
  72. c7c49ed HTTPCLIENT-2432: fix connection-pool leak in ResponseEntityProxy.cleanup() when disconnectEndpoint() throws (#883) by Victor Alekseev · 8 weeks ago
  73. be07c77 Use Brotli4jLoader.isAvailable() instead of relying on class presence. by Arturo Bernal · 3 months ago
  74. dd74a83 decode punycode public suffixes in PublicSuffixMatcher.verify (#876) by Javid Khan · 3 months ago
  75. 86c313b Fix Brotli async client example by Arturo Bernal · 3 months ago
  76. a01e51d Fix Brotli decompression hang with large input buffers by Arturo Bernal · 3 months ago
  77. 0bd4895 Add a model and parser for the RFC 9209 Proxy-Status response field by Arturo Bernal · 3 months ago
  78. 83386f2 RFC 9211: optional Cache-Status response header by Arturo Bernal · 3 months ago
  79. 6ed50d9 treat malformed delta-seconds as absent in deltaSeconds by Javid Khan · 3 months ago
  80. 8b901f8 Moved timeout and stale connection related integration tests into separate groups to be executed manually during release preparation due to those tests failing intermittently in CI by Oleg Kalnichevski · 3 months ago
  81. 3b2aeb1 Header parsing optimization in cookie, authentication and caching protocol code by Oleg Kalnichevski · 3 months ago
  82. 9128f74 Corrected report declarations of new project modules by Oleg Kalnichevski · 3 months ago
  83. 1ce37cb Deprecate the never-cache-responses-with-query options and make them opt-in by Arturo Bernal · 3 months ago
  84. ff52680 Add WebSocket RFCs to the standards compliance list by Arturo Bernal · 3 months ago
  85. 038378f Verify the server authentication (rspauth) provided in the Digest Authentication-Info response per RFC 7616 by Arturo Bernal · 3 months ago
  86. cb0062c Removed invalid request version check from ResponseCachingPolicy by Oleg Kalnichevski · 3 months ago
  87. 9765867 Fix resource leaking on error in AsyncCachingExec by Jeremie Bolduc · 3 months ago
  88. dbb9e86 Upgraded HttpClient version to 5.7-alpha2-SNAPSHOT by Oleg Kalnichevski · 3 months ago
  89. a890ec7 Corrects application of SSL parameters in the async TLS upgrade method by Oleg Kalnichevski · 3 months ago
  90. 4dae8da Javadoc fixes by Oleg Kalnichevski · 3 months ago
  91. c28479e Integration tests failing intermittently in the CI environment moved to 'slow' group by Oleg Kalnichevski · 3 months ago
  92. e43c290 Mark the SSE and WebSocket modules as experimental by Arturo Bernal · 3 months ago
  93. e23b8e7 Revise RELEASE_NOTES for version 5.7 by Gary Gregory · 3 months ago
  94. 3b4ff29 Add Experimental. to SSE and WebSocket by Arturo Bernal · 3 months ago
  95. 64916ee Updated release notes for HttpClient 5.7-alpha1 by Oleg Kalnichevski · 4 months ago
  96. ab543f1 Enable multiplex message exchanges over active HTTP/2 connections by Oleg Kalnichevski · 4 months ago
  97. 920be79 Hardened WebSocket transport and permessage-deflate for RFC 6455/7692 conformance by Arturo Bernal · 4 months ago
  98. 23a70f9 reject control characters in bearer token in BearerScheme by Javid Khan · 4 months ago
  99. c84facd Removed racy assert by Oleg Kalnichevski · 4 months ago
  100. b1c4b20 Disabled reactive HEAD request integration tests failing intermittently with CI build server by Oleg Kalnichevski · 4 months ago