Bump hive.version from 1.0.0 to 3.1.2

Bumps `hive.version` from 1.0.0 to 3.1.2.

Updates `hive-exec` from 1.0.0 to 3.1.2

Updates `hive-metastore` from 1.0.0 to 3.1.2

Updates `hive-hcatalog-streaming` from 1.0.0 to 3.1.2

Updates `hive-hcatalog-core` from 1.0.0 to 3.1.2

Updates `hive-cli` from 1.0.0 to 3.1.2

Signed-off-by: dependabot[bot] <support@github.com>
1 file changed
tree: e706ed9a0211ff431035aeb9562157c08f777a96
  1. .gitignore
  2. .mvn/
  3. .travis.yml
  4. CHANGELOG
  5. CONTRIBUTING.md
  6. DEVNOTES
  7. LICENSE
  8. NOTICE
  9. README.md
  10. RELEASE-NOTES
  11. bin/
  12. build-support/
  13. conf/
  14. dev-docs/
  15. dev-support/
  16. doap_Flume.rdf
  17. flume-ng-auth/
  18. flume-ng-channels/
  19. flume-ng-clients/
  20. flume-ng-configfilters/
  21. flume-ng-configuration/
  22. flume-ng-core/
  23. flume-ng-dist/
  24. flume-ng-doc/
  25. flume-ng-embedded-agent/
  26. flume-ng-legacy-sources/
  27. flume-ng-node/
  28. flume-ng-sdk/
  29. flume-ng-sinks/
  30. flume-ng-sources/
  31. flume-ng-tests/
  32. flume-shared/
  33. flume-tools/
  34. mvnw
  35. mvnw.cmd
  36. pom.xml
README.md

Welcome to Apache Flume!

Apache Flume is a distributed, reliable, and available service for efficiently collecting, aggregating, and moving large amounts of log data. It has a simple and flexible architecture based on streaming data flows. It is robust and fault tolerant with tunable reliability mechanisms and many failover and recovery mechanisms. The system is centrally managed and allows for intelligent dynamic management. It uses a simple extensible data model that allows for online analytic application.

The Apache Flume 1.x (NG) code line is a refactoring of the first generation Flume to solve certain known issues and limitations of the original design.

Apache Flume is open-sourced under the Apache Software Foundation License v2.0.

Documentation

Documentation is included in the binary distribution under the docs directory. In source form, it can be found in the flume-ng-doc directory.

The Flume 1.x guide and FAQ are available here:

Contact us!

Bug and Issue tracker.

Compiling Flume

Compiling Flume requires the following tools:

  • Oracle Java JDK 1.8
  • Apache Maven 3.x

Note: The Apache Flume build requires more memory than the default configuration. We recommend you set the following Maven options:

export MAVEN_OPTS="-Xms512m -Xmx1024m"

To compile Flume and build a distribution tarball, run mvn install from the top level directory. The artifacts will be placed under flume-ng-dist/target/.