Bump jetty-server from 9.1.0.v20131115 to 10.0.10 in /remoting

Bumps [jetty-server](https://github.com/eclipse/jetty.project) from 9.1.0.v20131115 to 10.0.10.
- [Release notes](https://github.com/eclipse/jetty.project/releases)
- [Commits](https://github.com/eclipse/jetty.project/compare/jetty-9.1.0.v20131115...jetty-10.0.10)

---
updated-dependencies:
- dependency-name: org.eclipse.jetty:jetty-server
  dependency-type: direct:development
...

Signed-off-by: dependabot[bot] <support@github.com>
1 file changed