Bump zookeeper from 3.4.6 to 3.4.14 in /framework (#604)

Bumps zookeeper from 3.4.6 to 3.4.14.

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
diff --git a/framework/pom.xml b/framework/pom.xml
index 494c950..87e7ffa 100644
--- a/framework/pom.xml
+++ b/framework/pom.xml
@@ -28,7 +28,7 @@
     <dependency>
       <groupId>org.apache.zookeeper</groupId>
       <artifactId>zookeeper</artifactId>
-      <version>3.4.6</version>
+      <version>3.4.14</version>
     </dependency>
     <dependency>
       <groupId>log4j</groupId>